Skip to main content

Clearing HSTS settings to fix a "Too many redirects" Page report error

Modified on: Thu, 2 Jul, 2026 at 3:43 PM

Answer

A "Too many redirects" error can occur when loading a Page Report for an HTTP page that has HTTP Strict Transport Security (HSTS) enabled. Clearing the HSTS settings for the affected domain in your browser typically resolves the issue.

Symptoms

You may experience the following:

  • A "Too many redirects" error when loading a Page Report.
  • The Page Report fails to open successfully.

Prerequisites

Before following the resolution steps:

  • You are attempting to load a Siteimprove Page Report.
  • The error displayed is "Too many redirects".

Cause

A "Too many redirects" error can occur when you are loading a Page report for an “HTTP” page that has HTTP Strict Transport Security (HSTS) enabled. HSTS is a web security policy mechanism that helps to protect websites from attack. The Page report environment attempts to redirect from HTTPS to HTTP, but if the original page has HSTS enabled, then the browser will automatically re-redirect the user back to HTTPS, causing an infinite loop. The browser sees this and responds with a "Too many redirects" error.

Resolution

If you encounter a "Too many redirects" error when loading a page report, we recommend that you clear HSTS Browser Settings as described below.

Resolution for Chrome

Delete the HSTS cache from your Chrome browser as follows:

  1. Open Google Chrome.
  2. Enter chrome://net-internals/#hsts in your address bar.
  3. In the “Query HSTS/PKP domain” field enter the domain name “my2.siteimprove.com”.
  4. Enter the domain “my2.siteimprove.com” in the “Delete domain security policies” field and press the Delete button.
  5. Restart the Chrome browser.clearing HSTS settings in chrome

Resolution for Firefox

  1. Close any other open Firefox windows and tabs.
  2. Open your browsing history by clicking Ctrl + Shift + H.
  3. Go to the site for which you want to clear the HSTS settings (i.e. my2.siteimprove.com)
  4. Right-click on the site and click on “Forget About This Site”.
    Note: This will clear all data of the site that is currently in Firefox.Deleting the cache History in Firefox

Resolution for Other Browsers

HSTS settings can be cleared in a similar way on other browsers. Please refer to your browser's help resources for specific information.

Still Need Help?

Please contact Siteimprove technical support if this does not resolve your issue.

Did you find it helpful? Yes No

Send feedback
Sorry we couldn't be helpful. Help us improve this article with your feedback.